perl cgi script for amino acids.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 

27 lines
758 B

{
description = "Juni's Vanilla Flake Template";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-22.05";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }:
with flake-utils.lib;
eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
version = "0.1.0";
name = "package name";
server = pkgs.writeShellScriptBin "server" ''
lighttpd -D -f ./lighttpd.conf
'';
in {
devShell = pkgs.mkShell { buildInputs = with pkgs; [ lighttpd perl server ]; };
defaultPackage = pkgs.stdenv.mkDerivation { inherit name version; };
formatter = nixpkgs.legacyPackages."${system}".nixfmt;
});
}