You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
34 lines
946 B
34 lines
946 B
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
|
# and may be overwritten by future invocations. Please make changes
|
|
# to /etc/nixos/configuration.nix instead.
|
|
{ config, lib, pkgs, modulesPath, ... }:
|
|
|
|
{
|
|
imports =
|
|
[ (modulesPath + "/profiles/qemu-guest.nix") ];
|
|
|
|
# Use the systemd-boot EFI boot loader.
|
|
boot.loader.grub = {
|
|
enable = true;
|
|
version = 2;
|
|
device = "/dev/vda";
|
|
};
|
|
networking.hostName = "nixbox"; # Define your hostname.
|
|
|
|
boot.initrd.availableKernelModules = [
|
|
"ahci" "xhci_pci" "virtio_pci"
|
|
"sr_mod" "virtio_blk"
|
|
];
|
|
|
|
boot.initrd.kernelModules = [ ];
|
|
boot.kernelModules = [ "kvm-intel" ];
|
|
boot.extraModulePackages = [ ];
|
|
|
|
fileSystems."/" =
|
|
{ device = "/dev/disk/by-label/nixos";
|
|
fsType = "ext4";
|
|
};
|
|
networking.useDHCP = lib.mkDefault true;
|
|
|
|
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
}
|