You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
36 lines
760 B
36 lines
760 B
{ config, pkgs, ... }:
|
|
{
|
|
|
|
environment.systemPackages = with pkgs; [
|
|
vim nano
|
|
wget curl
|
|
neofetch
|
|
screen tmux fff
|
|
bash dash git
|
|
docker-compose
|
|
nodejs
|
|
];
|
|
|
|
virtualisation.docker.enable = true;
|
|
programs.gnupg.agent = {
|
|
enable = true;
|
|
enableSSHSupport = true;
|
|
};
|
|
|
|
programs.zsh.enable = true;
|
|
programs.zsh.ohMyZsh.enable = true;
|
|
programs.zsh.autosuggestions.enable = true;
|
|
programs.zsh.shellAliases = {
|
|
"gac" = "git add . && git commit";
|
|
"v" = "nvim";
|
|
"c" = "clear";
|
|
"s" = "ls";
|
|
"e" = "exit";
|
|
"sy" = "systemctl";
|
|
"cp" = "cp -r";
|
|
};
|
|
programs.zsh.ohMyZsh.plugins = [ "git" "command-not-found" ];
|
|
programs.zsh.syntaxHighlighting.enable = true;
|
|
|
|
programs.starship.enable = true;
|
|
}
|