NixOS configs
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

138 lines
4.2 KiB

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running ‘nixos-help’).
{ config, pkgs, ... }:
{
# Use the GRUB 2 boot loader.
boot.loader.grub.enable = true;
boot.loader.grub.version = 2;
# boot.loader.grub.efiSupport = true;
# boot.loader.grub.efiInstallAsRemovable = true;
# boot.loader.efi.efiSysMountPoint = "/boot/efi";
# Define on which hard drive you want to install Grub.
boot.loader.grub.device = "/dev/vda"; # or "nodev" for efi only
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
# Set your time zone.
time.timeZone = "US/Eastern";
# The global useDHCP flag is deprecated, therefore explicitly set to false here.
# Per-interface useDHCP will be mandatory in the future, so this generated config
# replicates the default behaviour.
networking.useDHCP = false;
networking.interfaces.enp1s0.useDHCP = true;
# Configure network proxy if necessary
# networking.proxy.default = "http://user:password@proxy:port/";
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
# Select internationalisation properties.
i18n.defaultLocale = "en_US.UTF-8";
console = {
font = "Lat2-Terminus16";
keyMap = "us";
};
# Enable the X11 windowing system.
services.xserver.enable = true;
# use nix flakes
nix = {
package = pkgs.nixFlakes; # or versioned attributes like nix_2_7
extraOptions = ''
experimental-features = nix-command flakes
'';
};
# Configure keymap in X11
services.xserver.layout = "us";
services.xserver.xkbOptions = "eurosign:e";
# Enable CUPS to print documents.
# services.printing.enable = true;
# Enable sound.
sound.enable = true;
hardware.pulseaudio.enable = true;
# Enable touchpad support (enabled default in most desktopManager).
services.xserver.libinput.enable = true;
# Define a user account. Don't forget to set a password with ‘passwd’.
users.users.junikim = {
isNormalUser = true;
extraGroups = [ "wheel" "video" "audio" "input" ]; # Enable ‘sudo’ for the user.
shell = pkgs.zsh;
};
programs.zsh.enable = true;
programs.zsh.ohMyZsh.enable = true;
programs.zsh.autosuggestions.enable = true;
programs.zsh.shellAliases = {
"gac" = "git add . && git commit";
"v" = "nvim";
"c" = "clear";
"s" = "ls";
"e" = "exit";
"sy" = "systemctl";
"cp" = "cp -r";
};
programs.zsh.ohMyZsh.plugins = [ "git" "command-not-found" ];
programs.zsh.syntaxHighlighting.enable = true;
nixpkgs.config.allowUnfree = true;
environment.homeBinInPath = true;
environment.variables = {
"EDITOR" = "nvim";
};
services.gnome.gnome-keyring.enable = true;
# List packages installed in system profile. To search, run:
# $ nix search wget
fonts.fonts = with pkgs; [
jetbrains-mono
dejavu_fonts
noto-fonts-emoji
iosevka
];
environment.systemPackages = with pkgs; [
vim neovim neofetch pfetch tmux
fff
nodejs shellcheck
bash dash git
wget brave scrot
nfs-utils gcc gnumake
];
# Some programs need SUID wrappers, can be configured further or are
# started in user sessions.
# programs.mtr.enable = true;
programs.gnupg.agent = {
enable = true;
#enableSSHSupport = true;
};
# List services that you want to enable:
# Enable the OpenSSH daemon.
# services.openssh.enable = true;
# Open ports in the firewall.
# networking.firewall.allowedTCPPorts = [ ... ];
# networking.firewall.allowedUDPPorts = [ ... ];
# Or disable the firewall altogether.
# networking.firewall.enable = false;
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions
# on your system were taken. It‘s perfectly fine and recommended to leave
# this value at the release version of the first install of this system.
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
#system.stateVersion = "21.11"; # Did you read the comment?
system.stateVersion = "unstable"; # Did you read the comment?
}